Und wieder gab es ein Update von Divi bei dem folgende Änderungen durchgeführt wurden:

Version 3.21 (Das Update kam am 14.03.2019)
– CSS-Transformationsoptionen für alle Abschnitte, Zeilen und Module wurden hinzugefügt, so dass Benutzer die Position eines jeden Elements skalieren, drehen, verzerren und verschieben können.
– Das Kopieren/Einfügen wurde korrigiert, wodurch unter Umständen die falsche Einstellung geändert wurde.
– Es wurde ein Fall behoben, in dem das mehrfache Einfügen derselben Styles dazu führen konnte, dass sie zurückgesetzt wurden.
– Es wurde ein Fehler behoben, der dazu führte, dass das Laden eines Layouts von bestehenden Seiten nicht korrekt funktionierte.
– Die Kompatibilität des Event Managers wurde korrigiert.
– Es gab ein Problem beim Rendern mehrerer Module desselben Moduls im Category Builder.
– Es wurde ein Kodierungsproblem behoben, das beim Speichern von Optionen als Netzwerkadministrator auftreten konnte.
– Es wurde ein Kompatibilitätsproblem mit dem Events Schedule Plugin behoben.
– Verbesserte Protokollierung von Informationsmeldungen für die Support Center-Funktionalität.
– Es wurde eine PHP-Warnung behoben, die beim Versuch auftrat, eine Datei aus dem falschen Verzeichnis zu finden und zu verwenden, wenn mehrere ET-Produkte verwendet wurden.

ORIGINALTEXT: version 3.21 ( updated 03-14-2019 )
– Added CSS transform options to all sections, rows, and modules, allowing users to scale, rotate, skew, and offset the position of any element.
– Fixed copy/paste altering the wrong setting under some circumstances.
– Fixed a case where pasting the same styles multiple times could result in them to be reset.
– Fixed a bug that could cause loading a layout from existing pages not to work correctly.
– Fixed Events Manager compatibility.
– Fixed issue with rendering multiple of the same module in the category builder.
– Fixed an encoding issue that could occur while saving options as Network Admin.
– Fixed a compatibility issue with Events Schedule Plugin.
– Improved logging of informational messages for Support Center functionality.
– Fixed a PHP warning that occurred when trying to locate and use a file from the wrong directory when using multiple ET products.

Betroffene Dateien
* core/admin/js/support-center.js
* core/components/SupportCenter.php
* core/components/SupportCenterMUAutoloader.php
* core/components/mu-plugins/SupportCenterSafeModeDisablePlugins.php
* epanel/core_functions.php
* includes/builder/class-et-builder-element.php
* includes/builder/core.php
* includes/builder/feature/Library.php
* includes/builder/frontend-builder/bundle.js
* includes/builder/frontend-builder/helpers.php
* includes/builder/frontend-builder/i18n/library.php
* includes/builder/functions.php
* includes/builder/module/field/Border.php
* includes/builder/module/field/Transform.php

Aufrufe: 1